vendredi 19 juillet 2013

Avoir les bonnes fréquences 3G sur son smartphone chinois

Avoir les bonnes fréquences sur son smartphone chinois ne serait qu'une question de firmware ?
J'ai trouvé ce tuto pour rendre, de nouveau, compatible avec la fréquence 3G 900 Mhz l'Umi S1, qui perd cette compatibilité en mettant à jour son firmware :

"Pour répondre à vos réinterrogations, je dirai que ça dépend des versions de Firmware :
- avec le firmware v106, on a le droit aux 3 bandes de fréquence : 900 MHz, 1900 MHz, et 2000 MHz ;
- mais à partir du firmware v108, puis v109 : 2000 MHz seulement :-(

Heureusement, vous pouvez installer le fichier "modem.img" de la version 106 dans une version 108 ou 109 pour avoir toutes les plages de fréquences. Mais... ça n'est pas si simple. En effet, si vous faites ça directement, pour une raison que j'ignore, ça ne marche pas ! Seule solution que j'ai trouvée : passer par un fichier "modem.img" d'une ROM qui n'est pas prévue pour notre UMI S1, qui ne marche pas d'ailleurs, mais dont le passage dans notre téléphone réactive les fréquences perdues (ne me demandez pas pourquoi/comment, je n'ai pas compris).

Bref, pour avoir les 3 bandes en 3G+, voici la procédure :

1) faites un backup de votre Carte SD (pas sûr que ce soit indispensable, mais j'ai déjà eu une mauvaise excpérience), et téléchargez/copiez ces 3 fichiers sur cette carte : 
- http://desvigne.org/divers/telephonie/MT6589_modem_v7_08.05.2013.zip
- http://desvigne.org/divers/telephonie/modem_v106_MOLY.WR8.W1248.MD.WG.MP.V6.P4.zip
- http://desvigne.org/divers/telephonie/modem_v109_MOLY.WR8.W1248.MD.WG.MP.V6.P10.zip

2) rebootez en CWM recovery, et installez le mauvais (mais nécessaire) fichier "image.img" à l'aide de ce script : MT6589_modem_v7_08.05.2013.zip

3) démarrez le téléphone normalement. Attention: à ce stade, vous ne devriez pas avoir la 3G, voire même pas la 2G+ non plus. C'est normal, le firmware modem version 7 que vous venez d'installer ne marche pas avec le UMI S1 (mais il ne faut pas court-circuiter cette étape pour autant). 

4) rebootez à nouveau en CWM recovery, et installez le fichier "modem.img" qui était livré avec le firmware v.106 à l'aide de ce script : modem_v106_MOLY.WR8.W1248.MD.WG.MP.V6.P4.zip

5) démarrez à nouveau votre téléphone normalement. Entrez dans le mode ingénieur en composant le *#*#3646633#*#* , et vérifiez que les 3 bandes de fréquences sont bien activées : 900 MHz, 1900 MHz et 2000 MHz :-)

Si quelque chose devait mal tourner, pas de panique. Vous pouvez toujours remettre le fichier "modem.img" qui est livré avec les firmware v108 ou v109. Pour-ce, bootez en CWM recovery, et lancez ce script : modem_v109_MOLY.WR8.W1248.MD.WG.MP.V6.P10.zip (mais vous n'aurez alors que la bande des 2000 MHz en 3G)."
Merci à ManuD_Linux pour le partage.
Retrouvez le post complet sur le forum jtgeek...
Si vous avez des procédures de ce type pour d'autres modèles, n'hésitez pas à me les envoyer.

2 commentaires:

  1. Ce commentaire a été supprimé par l'auteur.

    RépondreSupprimer
  2. Salut
    Pourquoi avoir supprimé ton message ?
    J'ai lu le sujet sur FrAndroid : il est très instructif. C'est un lien à partager avec le plus grand nombre.

    RépondreSupprimer